Patiesā fragmentācija

323074-android-fragmentation-infographic

Bija tādi laiki, kad Apple aizstāvji izmantoja maģisko vārdu “fragmentācija” kā vienu no argumentiem pret Android. Tajos laikos, Android versijas iznāca ātri, un bieži vien jaunās versijas neatbalstīja vecos telefonus. Lietotāji sūdzējās, ka iznāk jauns Android, taču viņiem ir liegts to instalēt. Protams, savā mērā tas notiek arī joprojām, mans Sony telefons oficiāli neko virs 4.0.3 neredzēs, lai arī liekot visādus Hacks tur var uzlikt arī jaunākas versijas.
Bet galdiņi ir pagriezušies, un iOS piekāš cilvēkus vēl ļaunāk nekā Android. Uz Android vismaz viss turpina strādāt, tu vienkārši neredzi jaunāko operētājsistēmu, un daudziem tas patiesi neinteresē.

iPhone 3G šobrīd oficiāli var uzlikt iOS 4.2.1, kura lai arī strādā, diezgan smagi bremsē. Taču uzinstalēt programmas šeit ir visai sarežģīti – gandrīz jebkura programma apgalvo, ka neatbalsta iOS4. Nemaz nerunājot par visai ātri strādājošo iOS3 – uzliekot to, palaist nevar gandrīz neko. Pastāv variants meklēt ne-Appstore programmu failus, tos krekot, un lietot to vecās versijas. Tiesa gan, tas izrādās nestrādā ar programmām, kuras darbojas onlainā (Twitter, Facebook, Instagram). Pat jaunākajā iOS 4.2.1 (kuru var uzlikt uz iPhone 3G) Instagram paziņo, ka tik vecu operētājsistēmu neatbalsta. Uzliekot vecāku Instagram versiju, tas paziņo, ka programma ir par vecu, lai varētu pieslēgties serveriem. Kas rezultātā ir maģiskais aplis.

Error_Your_version_of_Instagram_is_out_of_date_iPhone_3G_PierreP
Error_Your_version_of_Instagram_is_out_of_date_iPhone_3G_PierreP

Oficiāli uzinstalēt uz iPhone 3G nav iespējams neko – vismaz ne no AppStore. Pat Angry Birds paziņo, ka nedarbojas, jo telefonam nav OpenGL komponenšu kas ieviestas tikai iOS 4.3. Bet kā jau teicu, pastāv vairāki veidi kā to apiet (viens no tiem, ja iTunes agrāk ir veidojis Backup, tad no tā var uzinstalēt programmu backupotās vecās versijas. Darbosies tikai dažas, online servisu programmas var arī nestrādāt).

Te nu bija fragmentācija.

36 thoughts on “Patiesā fragmentācija

  1. Tagad padomā kas ir fragmentācija?Protams, piecus gadus vecs telefons vairs neatbalsta visas jaunās fīčas. Tas ir tikai loģiski. Labāk tad ir paskatīties uz andrīti ar entajiem telefoniem, hardwārēm, ekrāniem, vēl visādiem UI un katram saviem niķiem un stiķiem. Androīds tāpat ir un paliks lieliska operētājsistēma, bet par fragmentāciju starp šīm abām īsti nav ko strīdēties. Atliek pavērot vien aplikāciju ekosistēmas kvalitāti.

    1. Tu nesaproti. Man nevajag jaunās fīčas, es tikai vēlos, lai programma kas man bija pirms 3 gadiem, strādā arī šodien. Šobrīd tas nav iespējams.

  2. man ir grūti salīdzināt situāciju kad ir iespējams nopirkt jaunu telefonu ar android 2.3, kas ir 2 OS paaudzes aiz jaunākās, bez jebkādām cerībām to apgreidot uz jaunāko OS ar piecus gadus vecu iphone 3G kuram nevar uzlikt jaunākās programmu versijas. kaut kas ar argumentāciju te neiet kopā.

  3. Tiešām? Viss cepiens par 5 (!!!) gadus vecu telefonu? Kā tev šķiet, cik labi šobrīd darbosies tikpat vecs Android telefons? Lai nav jāzvejo Internetos konkrēti modeļi, pateikšu priekšā – HTC Dream. Priecājies, ka ar savu 5 gadus veco telefonu vispār vēl vari veikt zvanus.

    1. Man ir vecs, vecs HTC Desire, un tici vai nē – man nav bijušas nekādas problēmas ar aplikācijām. Ar nevienu, lol.

  4. Nu gan jau sāk runāt kā pattērētāju sabiedrība @ USA :@ vāksja telefons kalpo labi un ir pirkts pa lielu naudu pirms 5 gadiem kāpēc būtu jāpērk jauns ?
    protams šādi vecie telefoni neļauj pilnībā izpausties programmu veidotājiem jo ir jādomā ka uz tada vecā telefona vis daudz maz kustēsies , vienkāršāk ir nogreizt suportu.
    bet jā uz pie uz tā paša HTC Hero ~4gadi vecs telefons var vienkārši uzlikt 2.3 android un pilnvērtīgi lieto visas android fičas tik lēni ….

  5. Tu manuprāt te jauc “fragmentāciju” ar tehnoloģiju “novecošanos”.
    Tev, protams, ir taisnība, ka Apple smartfonu ekosistēmā ir parādījusies fragmentācija – gan ekrānu izmēros (sākot ar iPhone5, kuram vairs nepietiek ar papildus grafisko elementu komplektu retinas izšķirtspējai bet jārēķinās ar atšķirīga izvietojuma ekrāna mainīto proporciju dēļ) gan opsistēmas versijām (lai arī iOS 4, 5 un 6 būtiski atšķiras, praktiski jāizšķir pre 4.3 un post 4.3 versijas, jo 2G un 3G nav iespējams uzlikt jaunāku opsistēmu kā 4.2.1, savukārt visiem aparātiem sākot ar 3GS joprojām ir iespējams uzlikt pašu jaunāko 6.2.1 opsistēmu). Droši vien ja ne ar iOS7 tad ar iOS8 noteikti fragmentācija Apple telefonu opsistēmu jomā palielināsies (piemēram iPhone 3GS un 4 pēdējā iepsējamā iOS versija būs 6.2.1 vai iOS 7.3).

    Taču Tev nav taisnība, ka “iOS cilvēku piekāš”, lietotāju piekāš app izstrādātāji (piem. tavā gadījumā Instagram u.c.), kuri izvēlas ne tikai netaisīt jaunāko app atbalstu vecajai iOS 4.2 versijai, bet sačakarē veco (jau instalēto) versiju atbalstu savā servera galā. Jā, tā ir piečakarēšana.

    Taču atbalstīt iOS 4.2 opsistēmu šobrīd maksā dārgi (vesela virkne izstrādātājam ļoti būtisku uzlabojumu izstrādes vidē un API nav savietojamas ar vecajām versijām) un tur neredzu nekādu problēmu vai atšķirību starp Android izstrādātāju, kas izvēlas neatbalstīt Android 1.6 lietotājus (kuru joprojām ir daudz) vai Android 2.2 (kuru ir ļoti daudz). Tirgum ir savi likumi, lielākā daļa cilvēku aparātus nomaina 2-4 gadu laikā un tādēļ atteikties no 4.2 atbalsta ir loģiska izvēle.

    Android fragmentācija ir sliktāka ar to, joprojām veikalos tiek pārdoti aparāti ar 2.1 vai 2.2 opsistēmu, kuri NEKAD nevarēs tikt atjaunoti uz jaunāko šībrīža pieejamo opsistēmas versiju (to tu nevari apgalvot par veikalos pieejamajiem Apple aparātiem) līdz ar to izstrādātājam ir dārgāk, sarēžģītāk un resursietilpīgāk apvert tādu pat procentuālo tirgus daļu kā izstrādājot iOS 6 versijai.

  6. Kā patērētāju mani šāda situācija arī neapmierina neatkarīgi no platformas. Es saprotu, ka tehnoloģijas attīstās nenormāli ātri, bet pirkt jaunu telefonu ik pēc 2 gadiem, ja vecajam nav pilnīgi nekādas vainas, lai tikai varētu tikt pie jaunākajām programmatūras iespējām, ir nejēdzīgi. Mobilo operētājsistēmu veidotājiem un aparatūras ražotājiem vajadzētu vienreiz sākt kārtīgi domāt ar galvu un, ja reiz mēs šīs ierīces mūsdienās pielīdzinām datoriem, tad arī veidot tās analogas datoriem, kur pat uz 10 gadus veca dzelža var uzinstalēt jaunāko OS versiju ar visām tai atbilstošajām aplikācijām.
    Komentējot šo situāciju no izstrādātāja satupunkta, man jāsaka, ka atbalstīt vecākas OS versijas nav viegli, jo izstrādes rīkos visu laiku parādās jaunas iespējas, kas ir paredzētas tikai jaunākajām platformām un ar kuru palīdzību mēs varam veidot daudz labākas un kvalitatīvākas aplikācijas ar mazāku piepūli. Tāpat kā patērētājs vēlās jaunākās funkcijas savā telefonā, tāpat izstrādātājs vēlās jaunākās funkcijas savā darbarīkā.

  7. Es ar savu iepriekšējo HTC Desire jau sen sapratu, ka NEDRĪKST atjaunot aplikācijas uz jaunākām versijām, jo a) tās kļūst lielākas izmērā un tāpēc vairs neietilpst jau tā smieklīgi mazajā aplikāciju atmiņā (~110MB) un b) vecie dzelži to vnk nevar pavilkt 🙂
    Cik labi, ka tagad man ir Samsung Galaxy Nexus 😉 uz kura starp citu ir aptuveni 100 aplikācijas, kuras aizņem apmēram 1,6GB un darbojas ar pēdējo 4.2.1. androidu.

  8. Baigi priecājos beidzot redzēt Apple aizstāvjus 😀 Mērķis sasniegts. Protams taisnība, ka šo situāciju vairāk radījuši App izstrādātāji, bet fakts paliek.

Leave a Reply

Your email address will not be published. Required fields are marked *